Jump to content
Jon

NifSkope 2.0 Dev

Recommended Posts

Yes I have had this error turns out my free antivirus was acting like a virus had to uninstall I don't remember which one it was either AVG or avast. No amount of system exceptions or exclusions got it working uninstalling it was the only way to fix it. BTW I was able to get it to open a second nif if I selected the nif and hit enter about 10 times really fast on the keyboard. Just using Windows Defender now

Share this post


Link to post
Share on other sites

I have this issue too

and what I could find out is it happen since I switched to win 10

according to some information Win 10 suppresses many applications to start twice due double click, but starts a second or third nifscope window by opening a new window in the nifscope drop down menu.

 

 

Share this post


Link to post
Share on other sites

Is it possible to view the mesh data contained in the bhkPhysicsSystem node? Or better yet, merge multiple bhkPhysicsSystem nodes into one?

Reason for asking, is that I'm creating static objects out of the mannequins, and need to create new collision for them. If merging them is impossible, I'll have to make the collision mesh myself, and I'd like to see what the original collision looks like.

Share this post


Link to post
Share on other sites

I have encountered a nif that loads and displays fine in dev6, but has a load error in dev7.

The file is spcsphrorbitalstrike01.nif that ships with the Steam Workshop introduction mod Fall of the Space Core from Valve. 

Nothing of importance really. I just found it curios.

Share this post


Link to post
Share on other sites

Just discovered Nifscope 2 and am having an issue with specular.  When I import the female barkeepers clothes, all looks good except the body pieces.  The body has texture, but it looks very chocolate colored and the specular intensity is very high.   I know I can turn off specular under the render drop down, but is there a way to just tone it down?  Thanks in advance.

 

Also, when I close Nifscope, I always get a windows pop up saying that Nifscope has stopped working, etc.  That's not quite right me thinks.  Any word on that?

Bar.jpg

Share this post


Link to post
Share on other sites

Hi @Randy2575 ,

That's not an issue with NifSkope, it's an issue with the vanilla clothes meshes. A ton of them have a missing body texture and look like that. We fixed hundreds of them in USLEEP/USSEP.

Vanilla mesh;

skin1.jpg.01fc599ea72ce2fe73c6b865d9f548f0.jpg

 

USLEEP/USSEP fixed mesh;

skin2.jpg.2abdb2fd62e9d7629da00a3317c9d373.jpg

 

If you plan to do any work on vanilla armor/clothing, feel free to use the USLEEP/USSEP meshes as your starting point.

I can't help with your other issue on closing the program but if you come to the NifTools Discord server, you can find an updated version to try.

 

 

Share this post


Link to post
Share on other sites

Thanks Hana.  This actually isn't the vanilla body, but a CBBE body I added in Max.  I may have an outdated nif plugin for Max, I'll double check on that, it's Max v.2014.  So far the way I've been getting around this is by opening the exported Max file in nifscope, opening the CBBE body in another instance of nif, then copying the modified Max vanilla clothes and adding them to the CBBE body.  After that I export the clothes/body to the game directory in a new meshes folder.  This way the clothes and body appear correct, but it seems like a long roundabout way of getting there.

I am following nightasy's tutorials and must have missed something because his modified Max export  appears in game without going through the nifscope body/clothes changes? 

Do you know why any body that gets imported to Max shows up with the burned texture instead of the normal texture?  Even a CBBE body does this.  When I go into the CBBE folder and I look at a body with nif, it shows up fine.  When I import that same body to Max, it has the burned texture.  No big deal, but I'd like to know why it's doing that?  Even in nightasy's tutorials his imported bodies have the burned textures.

I just downloaded nifscope a couple of days ago, so I have the latest version.  Messing around on my computer, I may have found the reason why Nif was crashing all the time.  Nif was installed on an older external drive and I have reason to believe the drive is starting to fail.  Installed nif on another drive and am hoping for more stability.

It's a steep learning curve for me, but the results are strangely satisfying to see my own modifications in the game.

Thanks again

 

Cheers

Share this post


Link to post
Share on other sites

What body it is doesn't really have anything to do with it.  When you batch build it's just taking the geometry and morphing it, and leaving the broken texture set paths intact.  So for a preset or different base body that supplies vanilla refits, they batch built and didn't use the UP versions with the fixed texture paths.

What version of the plugin you have also has nothing to do with it.   It's going to import what textures are referenced in the original and export them back out.   The problem is in the original NIF and so anything is going to preserve this problem unless you add the texture path back in as Hana illustrated.

Also, I'm a bit fuzzy with actual game details at this point,  but the texture sets for bodies in the outfit NIFs hardly matter afaik, as the race/NPC/etc. records in the ESM file have texture sets that override all of this anyway.  Otherwise the outfits couldn't do skin swaps (like elder, briarheart, whatever else has different skin textures).   So, in most cases the game probably adds the missing specular mask back via the ESM's texture set swaps and the shininess in NifSkope from the missing _s map doesn't really matter. 

Share this post


Link to post
Share on other sites

I'm currently using NifSkope 2.0 Dev 7.

Used this to change the user version numbers from Skyrim to FO3 (?), 12/83 -> 11/34., then saved (Note: the file had previously been stripped of the collision, the BSShaderProperty blocks and the BSX flags). Upon trying to reload it, I got this warning:

[0] Array Properties invalid

Pos 376: failed to load block number 0 (BSFadeNode) previous block was NiHeader

Failed to load F:/Skyrim Mod Projects/Nifs for Blender Import/dwermsmcolumnfixed01_raw_01.nif

 

Loaded the stripped file in old NifSkope, changed the user version numbers there and saved. This file loads fine (i.e. without that error) in both old NifSkope and NifSkope 2.0.

Share this post


Link to post
Share on other sites

Hi Sclero,

I've questioned this same thing before and it's not a bug or error, Nifskope 2.0 just doesn't do that any more. The answer I got was it was a "happy accident" it ever did it at all, it was never an intended feature and with all the recoding of 2.0 that's gone and will not be supported again.

You'll have to continue using an older version for that F03 workflow.

Share this post


Link to post
Share on other sites

Fallout 76 uses 20.2.0.7 version of file but february nifskope unable to load it because this files doesnt contain HKT filepath string anymore. Can this be fixed?

Share this post


Link to post
Share on other sites

That's not strictly correct.  That's one of two header differences, not to mention differences in many other blocks.  I've already fixed all of it but I have no plans for a release at this time. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Support us on Patreon!

×