Jump to content
Sclerocephalus

Issues with random encounters

Recommended Posts

On 22.4.2017 at 2:00 PM, ChaosWarrior said:

by the way it is not retroactive if used as plugin.... which is weird... may be something else is setting this global and it would explain high chance. You can check it in console using "help DLC01RE 3" line and set with "set DLC01REPercentChance to 33" line. I was thinking about what value I should use and stopped at 33 because those RE are action packed in contrast with "gassy settler" so 25 may be not enough. 1/3 seems fair.

I tried to change the value DLC01REPercentChance from 50.0 to 25.0. Also I changed the DLC01LoadScreenRate from 20.0 to 5.0. Both changes were done with xEdit (not with the CK). I stored both records into a esp-file. Then I checked all, and both values showed as changed in xedit.

I started a new game, and additionally had the start of DLC01 delayed to level 30 (by a loose file changed script, which worked fine). When I became level 30 in this new game (always using my mod file, and nothing else except UFO4P) the DLC01 started normally, I met Ada, sent her to a settlement - then I removed the changed script. (In the script only one comparison was changed, so that the main quest started with level 30, not 15).

But continuing to play I found, that there were much more DLC01 random encounters, and much more DLC01 workshop attacks. Where I go I see either Mechanists or Raider robot groups, a lot more than I remember from earlier games. I was sent to Abernathy (by Minutemen Radio) and there was a massive attack in progress, for example. I never visited Abernathy in this game before that.

It may owned to my higher level (usually you start this in level 15). But both values, DLC01REPercentChance and DLC01LoadScreenRate are set to their original values! The mod seems to do nothing. I checked this with the help command in the console, but will not change it via console.

I suspect the naming of these variables creates a misunderstanding - they seem to work differently. Also, in the global section of DLC01 are much more variables, which are obviously changed later in the game.

I do not think it works well to change these variables, maybe in console it will work better, but it also may not...

I will restore my game to a save before level 30, remove my mod, and try it again. The mod seems to do nothing anyway. It also may be, that delaying the start of DLC01 is not a good idea..

 

Share this post


Link to post
Share on other sites

I started a new game (without any mods, including the mods above). So Automatron started with level 15 and the encounter rate is unchanged. I think, this encounter rate is influenced by the Automatron quest progress rate, after solving the Automatron main quest the encounters are much rarer.

But the entire game is changed now! Automatron encounters - for some reason - seem to be exceedingly hard. I play on Hard Difficulty, but I am not used to this encounters yet. All other encounters are quite well balanced, but robot encounters can be very hard, since there are One-Hit enemies. One hit, and the character dies from full health. Some encounters I cannot survive without chem use. It does not matter, and it may be as planned, but somehow it seems just harder now.

The rest of random encounters is much more diverse and fun, and there are lots of it. I think this is as the game was planned. There are well known encounter spots (for example the camp site just outside Concord), and they have encounters each time one passes.

Also BoS vertibird patrols are active, and seem to work better. They land, take somebody and start again, or they drop Knights in Power Armor and continue flying. The entire system seems better and makes more sense now. Vertibirds crash often, but only when shot down. Before they crashed somehow senseless.

Also the MM quest line seems to be much more streamlined - could it be that the story manager had problems with REs? Now the quest come in a measured rate, make sense, and one can even use the Radio, there will never be more than 3 quests at once. It becomes a bit hectic from time to time, since many of these quests are timed, so one should plan for this phase and not do much besides it. But it also seems as planned by the developers.

What regrettably still does not work are the Workshops. Without warning or obvious reason bed counts or food counts go the zero, or a much lower count. There is no clear trigger for this bug. Could it be that script load is now sometimes so heavy (because of REs which do not block themselves), that it sometimes does not complete?

Share this post


Link to post
Share on other sites

Sorry to necro this old thread.

I'm just wondering if there is a way to terminate these stuck Random Encounters? (On PC)

DLC01RETravelKMK02 (Robot's vs Rust Devils) totally locked up. Has been for what probably translates to a couple of in game weeks. Console indicates Stage 10 is active? but stage 500 and stage 1000 not. (I can't find any info on what those 2 stages actually are? Cleanup and stop/reset?

There must surely be a method on PC to clear this quest through console or otherwise? - I can find this quest referred to in FO4Edit - but oddly can not find an actual file with this name. (DLC01RETravelKMK01 exists but not DLC01RETravelKMK02)

I too have the Gassy settler (Longneck Lukovski quest giver), Random bar and burning tyres blocking up Random encounter zones. (as well as a stack of Radioactive waste barrels) - have completed Mystery Meat quest.

 

Share this post


Link to post
Share on other sites

Got it installed already and this Random Encounter lock up has occurred recently. (since install of UFO4P)

It's a great project by the way and I appreciate all the work that you have put into it. 

 

Is there a manual method to kill stuck random encounters or will reinstalling UFO4P actually do that?

Share this post


Link to post
Share on other sites

There is no safe way to do it manually. You could call Stop() on those quests, which properly shuts them down and also leads to all actors left by them in the game world to disappear very quickly. It does not solve the problem with the trigger though: to unblock the trigger, you need a script. It also does most likely not solve the problem with the actual encounter quest: once that quest starts running again, it will not shut down on its own.

Best wait therefore until all RE quests are eventually fixed. There appears to be a common misconception that we already did that, but that's not true (note that we also didn't claim to have it done already).

All random encounters are using a framework of common scripts, RETriggerScript (which runs on all triggers) and REScript (which runs on all RE quests). Depending on the encounter type and the design of specific RE quests, individual quests may be running other "random encounter scripts" in addition (e.g. REAssaultSC_FactionScript, REAssaultQuestScript, REChokepointTriggerScript and others). The basic functionality, which includes evaluation of the stop conditions, the subsequent shut down and rearming of the trigger is only handled by REScript and RETriggerScript though.

What we started with was to fix all bugs on these two scripts, and to add the trigger rearming procedure to REScript (while the vanilla quests were designed to do that on their own, they did never succeed in actually doing it because of an improperly used flag on their end fragments) . With these fixes, all RE quests that are properly set up would start working as expected again, and this applied in fact to more than two thrids of the RE quests in the game.

Emphasis here is on "properly set up": all quests need to set properties on their REScript to define appropriate shut down conditions, and likewise, all quests must call the Startup() function on REScript from their quest fragments, in order to make REScript register for cleanup events (it never evaluates the stop conditions if this hasn't been done). There were quite a number of quests that did not have any stop conditions defined, and they would never shut down on their own. This was the case with both DLC01RETravelKMK01 and DLC01RETravelKMK02. The 'gassy settler' is an example of a quest that never called Startup() on its REScript.

These problems (and many others) are quest specific and need to addressed by quest-specific fixes. This is still a work in progress.

  • DLC01RETravelKMK01 and DLC01RETravelKMK02 were supposedly fixed in UFO4P 2.0.0 but the modifications to the properties on REScript went missing when the mod was packed up for release after the beta phase. Both quests were still not working with UFO4P 2.0.1, but the fix has been redone in UFO4P 2.0.2 and is now working.
  • The gassy settler has been fixed in UFO4P 2.0.2

 

Share this post


Link to post
Share on other sites

I've noticed two areas that always have hostiles whenever I visit them -- even if it's only a day since my last visit.  The gated entrance to Starlight Drive-in where hostiles come from under the railroad overpass, and the second one is about a block or two NW of Hangman's Alley.  Whether I walk there or fly in on a Vertibird, I almost always encounter hostiles.  More than half the time it's hostiles added by Automatron.  Should these be respawning this quickly or is it a bug?

Share this post


Link to post
Share on other sites

I noticed a change in an encounter that in previous games has shown some activity that may be bugged or simply incomplete.

There's a random encounter that has a group of super mutants keeping a settler captive. What happened before is if you kill the super mutants the settler will run away and eventually end up in Sanctuary if you follow them. Then the settler can be moved to a settlement and assigned work, but he/she doesn't have any animations, nor do they actually seem to move if you send them somewhere else or make them a provisioner. The settler just stays at the same spot where they stop and nothing seems to happen. Usually I just leave Sanctuary without doing anything and the settler vanishes eventually.

It might be this week's update, but this time I clicked on the "interact" part I got a menu option to free the settler, do nothing or free/interact with opens their inventory. After I selected something I got a dialogue option similar to the encounter where you stop an attack on the settlers and you can send them to a settlement. In this case the settler was a woman and since the encounter was close to Sanctuary I sent her there. When she got there she stood at the same spot. I tried assigning her to a scavenging station and nothing seemed to happen. So I fast traveled away and back and she was working on the scavenging station and wandering off, the usual settler animations.

Since it happened after the update I'm wondering if Bethesda fixed something or if it was just something that's always been there but I never ran into it. No dev notes so far so I can't tell.

Anyway, just wanted to report it since it's one of the random encounters that's always acted wonky and it seems to be working for some reason.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Support us on Patreon!

×