Jump to content

Recommended Posts

19 minutes ago, Arthmoor said:

@alt3rn1ty I see the facepalm and the eye roll. What's the other one?

Facepalm and thumbsup were not showing for me, also innocent and horkercookie are the same on the selection, and quite a lot of them look tiny

H4BHkd4.png

Share this post


Link to post
Share on other sites

Crash report when starting beta 3.  This is for Oblivion.  Skyrim SE and Skyrim start ok.

File "bash\bash.pyo", line 227, in main
  File "bash\bash.pyo", line 393, in _main
  File "bash\basher\__init__.pyo", line 3981, in Init
  File "bash\basher\__init__.pyo", line 4021, in InitData
  File "bash\bosh\__init__.pyo", line 2726, in refresh
  File "bash\bosh\__init__.pyo", line 1382, in refresh
  File "bash\bosh\__init__.pyo", line 1358, in new_info
  File "bash\bosh\__init__.pyo", line 1277, in new_info
  File "bash\bosh\__init__.pyo", line 393, in __init__
  File "bash\bosh\__init__.pyo", line 274, in __init__
  File "bash\bosh\__init__.pyo", line 405, in _reset_cache
  File "bash\bosh\__init__.pyo", line 1108, in readHeader
  File "bash\bosh\save_headers.pyo", line 62, in __init__
  File "bash\bosh\save_headers.pyo", line 78, in load_header
  File "bash\bosh\save_headers.pyo", line 88, in load_image_data
OverflowError: Python int too large to convert to C long
 

Share this post


Link to post
Share on other sites

@Utumno I think you fixed my spurious issue with refresh (from a while back). Just tried recreating by installing a plugin with the Installers tab, go to mods tab, then open a windows window to manually duplicate the same file. Used xEdit on a few of the duplicates, then clicked the still open Wrye Bash to bring it into focus, and the refresh happened fine. Then went back to windows and manually deleted a few of them, back to Wrye Bash and the refresh picked up on the fact that a few were now missing without issue.

But I did get a bit more BashBugDump output than I thought I would :

Wrye Bash starting
Using Wrye Bash Version 307.201807040057 (Standalone)
OS info: Windows-10-10.0.17134
Python version: 2.7.12
wxPython version: 2.8.12.1 (msw-unicode)
input encoding: None; output encoding: None; locale: ('en_GB', 'cp1252')
filesystem encoding: mbcs
command line: ['D:\\Steam\\steamapps\\common\\Skyrim Special Edition\\Mopy\\Wrye Bash.exe', '-d']
Using scandir 1.5
bash.pyo  286 _main: Searching for game to manage:
bush.pyo   80 _supportedGames: Detected the following supported games via Windows Registry:
bush.pyo   82 _supportedGames:  Skyrim Special Edition: D:\Steam\steamapps\common\Skyrim Special Edition
bush.pyo   82 _supportedGames:  Fallout4: D:\Steam\steamapps\common\Fallout 4
bush.pyo  140 _detectGames: Detecting games via the -o argument, bash.ini and relative path:
bush.pyo  146 _detectGames: Set game mode to Skyrim Special Edition found in parent directory of Mopy:  D:\Steam\steamapps\common\Skyrim Special Edition
bush.pyo  161 __setGame:  Using Skyrim Special Edition game: D:\Steam\steamapps\common\Skyrim Special Edition
testing UAC
mods_metadata.pyo  230 __init__: Using LOOT API version: 0.13.2
games.pyo  767 _fetch_load_order: Removed Skyrim.esm ,Dragonborn.esm ,Hearthfires.esm ,Update.esm ,Dawnguard.esm from C:\Users\m0l3y\AppData\Local\Skyrim Special Edition\plugins.txt
games.pyo  161 warn_lo: Fixed Load Order: added(Arrow Speed - Copy (2).esp, Arrow Speed - Copy.esp, Arrow Speed - Copy (3).esp, Arrow Speed - Copy (4).esp), removed(None), reordered (No)
games.pyo  161 warn_lo: Fixed Load Order: added(None), removed(Arrow Speed - Copy (2).esp, Arrow Speed - Copy.esp, Arrow Speed - Copy (3).esp), reordered (No)
games.pyo  186 warn_active: Invalid Plugin txt corrected:
Active list contains mods not present in Data/ directory or corrupted: Arrow Speed - Copy (2).esp, Arrow Speed - Copy.esp, Arrow Speed - Copy (3).esp
 

The simpler scenario which I had a similar problem with before though, is no longer a problem :

Go to installers tab

Install a plugin

Go to mods tab, then right click and delete the same plugin using Wrye Bash own delete menu item

Go to Installers Tab

.. At this point previously, Wrye Bash would have crashed as soon as you went to the Installers Tab, now it does not

Wrye Bash starting
Using Wrye Bash Version 307.201807040057 (Standalone)
OS info: Windows-10-10.0.17134
Python version: 2.7.12
wxPython version: 2.8.12.1 (msw-unicode)
input encoding: None; output encoding: None; locale: ('en_GB', 'cp1252')
filesystem encoding: mbcs
command line: ['D:\\Steam\\steamapps\\common\\Skyrim Special Edition\\Mopy\\Wrye Bash.exe', '-d']
Using scandir 1.5
bash.pyo  286 _main: Searching for game to manage:
bush.pyo   80 _supportedGames: Detected the following supported games via Windows Registry:
bush.pyo   82 _supportedGames:  Skyrim Special Edition: D:\Steam\steamapps\common\Skyrim Special Edition
bush.pyo   82 _supportedGames:  Fallout4: D:\Steam\steamapps\common\Fallout 4
bush.pyo  140 _detectGames: Detecting games via the -o argument, bash.ini and relative path:
bush.pyo  146 _detectGames: Set game mode to Skyrim Special Edition found in parent directory of Mopy:  D:\Steam\steamapps\common\Skyrim Special Edition
bush.pyo  161 __setGame:  Using Skyrim Special Edition game: D:\Steam\steamapps\common\Skyrim Special Edition
testing UAC
mods_metadata.pyo  230 __init__: Using LOOT API version: 0.13.2

Share this post


Link to post
Share on other sites
34 minutes ago, alt3rn1ty said:

Facepalm and thumbsup were not showing for me, also innocent and horkercookie are the same on the selection, and quite a lot of them look tiny

H4BHkd4.png

They all look ok to me and I'm hotspotting on mobile so if they were gonna go screwy I'd expect it to happen to me too. May have just been a temporary thing? Anyway, this doesn't belong in the Bash thread so if it continues to be an issue we can move the posts to the site feedback forum.

Share this post


Link to post
Share on other sites
4 hours ago, Supierce said:

Wow! Congratulations on getting the beta out the door!! :)

I've been playing around with wxpython 3 and recommend moving to it soon - it's a definite improvement.

Haha I did not mean to so soon but alea jacta est - I still have to merge on dev

Thanks @alt3rn1ty, thanks indeed. I was planning to have this tested a bit but hey it's high time it was out.

@Sharlikran all the best with new pages - do add a sticky with the info on Valda's version vs ours (and the well know disclaimer that we need coders - I personally can not invest time in fo3/fnv, but I could n't have all this code dragging along dev and needing patching all the time - at least now it's bound to much newer/better Bash core) - @Dubious is setting up a porting guide - is that ready Dubious?

Share this post


Link to post
Share on other sites
1 hour ago, alt3rn1ty said:

@Utumno I think you fixed my spurious issue with refresh (from a while back). Just tried recreating by installing a plugin with the Installers tab, go to mods tab, then open a windows window to manually duplicate the same file. Used xEdit on a few of the duplicates, then clicked the still open Wrye Bash to bring it into focus, and the refresh happened fine. Then went back to windows and manually deleted a few of them, back to Wrye Bash and the refresh picked up on the fact that a few were now missing without issue.

But I did get a bit more BashBugDump output than I thought I would :

Wrye Bash starting
Using Wrye Bash Version 307.201807040057 (Standalone)
OS info: Windows-10-10.0.17134
Python version: 2.7.12
wxPython version: 2.8.12.1 (msw-unicode)
input encoding: None; output encoding: None; locale: ('en_GB', 'cp1252')
filesystem encoding: mbcs
command line: ['D:\\Steam\\steamapps\\common\\Skyrim Special Edition\\Mopy\\Wrye Bash.exe', '-d']
Using scandir 1.5
bash.pyo  286 _main: Searching for game to manage:
bush.pyo   80 _supportedGames: Detected the following supported games via Windows Registry:
bush.pyo   82 _supportedGames:  Skyrim Special Edition: D:\Steam\steamapps\common\Skyrim Special Edition
bush.pyo   82 _supportedGames:  Fallout4: D:\Steam\steamapps\common\Fallout 4
bush.pyo  140 _detectGames: Detecting games via the -o argument, bash.ini and relative path:
bush.pyo  146 _detectGames: Set game mode to Skyrim Special Edition found in parent directory of Mopy:  D:\Steam\steamapps\common\Skyrim Special Edition
bush.pyo  161 __setGame:  Using Skyrim Special Edition game: D:\Steam\steamapps\common\Skyrim Special Edition
testing UAC
mods_metadata.pyo  230 __init__: Using LOOT API version: 0.13.2
games.pyo  767 _fetch_load_order: Removed Skyrim.esm ,Dragonborn.esm ,Hearthfires.esm ,Update.esm ,Dawnguard.esm from C:\Users\m0l3y\AppData\Local\Skyrim Special Edition\plugins.txt
games.pyo  161 warn_lo: Fixed Load Order: added(Arrow Speed - Copy (2).esp, Arrow Speed - Copy.esp, Arrow Speed - Copy (3).esp, Arrow Speed - Copy (4).esp), removed(None), reordered (No)
games.pyo  161 warn_lo: Fixed Load Order: added(None), removed(Arrow Speed - Copy (2).esp, Arrow Speed - Copy.esp, Arrow Speed - Copy (3).esp), reordered (No)
games.pyo  186 warn_active: Invalid Plugin txt corrected:
Active list contains mods not present in Data/ directory or corrupted: Arrow Speed - Copy (2).esp, Arrow Speed - Copy.esp, Arrow Speed - Copy (3).esp
 

The simpler scenario which I had a similar problem with before though, is no longer a problem :

Go to installers tab

Install a plugin

Go to mods tab, then right click and delete the same plugin using Wrye Bash own delete menu item

Go to Installers Tab

.. At this point previously, Wrye Bash would have crashed as soon as you went to the Installers Tab, now it does not

Wrye Bash starting
Using Wrye Bash Version 307.201807040057 (Standalone)
OS info: Windows-10-10.0.17134
Python version: 2.7.12
wxPython version: 2.8.12.1 (msw-unicode)
input encoding: None; output encoding: None; locale: ('en_GB', 'cp1252')
filesystem encoding: mbcs
command line: ['D:\\Steam\\steamapps\\common\\Skyrim Special Edition\\Mopy\\Wrye Bash.exe', '-d']
Using scandir 1.5
bash.pyo  286 _main: Searching for game to manage:
bush.pyo   80 _supportedGames: Detected the following supported games via Windows Registry:
bush.pyo   82 _supportedGames:  Skyrim Special Edition: D:\Steam\steamapps\common\Skyrim Special Edition
bush.pyo   82 _supportedGames:  Fallout4: D:\Steam\steamapps\common\Fallout 4
bush.pyo  140 _detectGames: Detecting games via the -o argument, bash.ini and relative path:
bush.pyo  146 _detectGames: Set game mode to Skyrim Special Edition found in parent directory of Mopy:  D:\Steam\steamapps\common\Skyrim Special Edition
bush.pyo  161 __setGame:  Using Skyrim Special Edition game: D:\Steam\steamapps\common\Skyrim Special Edition
testing UAC
mods_metadata.pyo  230 __init__: Using LOOT API version: 0.13.2

Yep that one I fixed in latest iteration (namely here: https://github.com/wrye-bash/wrye-bash/commit/5d9915f7a0b57c1626b3001502cbfb47078e0f1b ) - don't worry about the load order debug prints - load order handling is one of the trickiest parts (remember liblo?) so I left some debug prints in there

Share this post


Link to post
Share on other sites
1 hour ago, Utumno said:

Haha I did not mean to so soon but alea jacta est - I still have to merge on dev

Thanks @alt3rn1ty, thanks indeed. I was planning to have this tested a bit but hey it's high time it was out.

Ah I read your post back here a couple of times .. and misinterpreted it.

Share this post


Link to post
Share on other sites

I am still working on it but I think what I have will suffice. I appreciate all the advice and tips. I do still maintain Valda's mods and on occasion some of my own with the new changes to the Nexus.  It's always good to share tips, observations, and advice especially when something is important and a labor of love so to speak.  It's just good practice so thanks for that.

Share this post


Link to post
Share on other sites
3 hours ago, Utumno said:

I personally can not invest time in fo3/fnv, but I couldn't have all this code dragging along dev and needing patching all the time - at least now it's bound to much newer/better Bash core.

I don't have much spare time myself.  It was just as tedious for me to rebase multiple branches. At times I needed one for LOOT, Skyrim/Skyrim SE, Fallout 4, FO3/FNV, and on top of all that rebase in or somehow off of utumno-wip. Once everything is finalized and in dev then I just have to rebase off of dev and get something done. Hopefully I will have time to do so. Thanks again.

@Dubious I still have to look at all the differences between Valda's versions. However for the mods folders Valda's is "Fallout 3 Mods" and "Fallout New Vegas Mods" and for 307 it's "Fallout3 Mods" and "FalloutNV Mods". While C:\Users\[User name]\Documents\My Games\[Game Mode] remains the same.

Share this post


Link to post
Share on other sites

Just posted the "migration guide", but it hasn't shown up on the WB Wiki "Home" page as yet.  My first post to the GitHub wiki, so I probably made a mistake.

I wrote and mentioned a script file (WFProfile.cmd) for helping a migrator to manage backups of the different version files.  However, have no idea where to post it and how to link to that location.  It's too long (44KB) to post in that article (though easy to customize).  Suggestions?

@Sharlikran: We cross-posted, so I will update the migration guide with that info.  Thanks.

-Dubious-

Share this post


Link to post
Share on other sites

 

2 hours ago, alt3rn1ty said:

Ah I read your post back here a couple of times .. and misinterpreted it.

Better that way - we have final 307 (come september) to correct bugs and anyway f3/nv merge was dragging along since forever

29 minutes ago, Sharlikran said:

I don't have much spare time myself.  It was just as tedious for me to rebase multiple branches. At times I needed one for LOOT, Skyrim/Skyrim SE, Fallout 4, FO3/FNV, and on top of all that rebase in or somehow off of utumno-wip. Once everything is finalized and in dev then I just have to rebase off of dev and get something done. Hopefully I will have time to do so. Thanks again.

@Dubious I still have to look at all the differences between Valda's versions. However for the mods folders Valda's is "Fallout 3 Mods" and "Fallout New Vegas Mods" and for 307 it's "Fallout3 Mods" and "FalloutNV Mods". While C:\Users\[User name]\Documents\My Games\[Game Mode] remains the same.

Yep having all those branches was a pain that would not lessen - hence I decided to go ahead and merge. I mean I have not played the games ever and what they especially need is patcher/record work which is not my area of expertise either (yet).

Once I merge to dev we go back to usual situation of utumn-wip on top of dev with  a much lighter utumno wip overall.

25 minutes ago, Dubious said:

Just posted the "migration guide", but it hasn't shown up on the WB Wiki "Home" page as yet.  My first post to the GitHub wiki, so I probably made a mistake.

I wrote and mentioned a script file (WFProfile.cmd) for helping a migrator to manage backups of the different version files.  However, have no idea where to post it and how to link to that location.  It's too long (44KB) to post in that article (though easy to customize).  Suggestions?

@Sharlikran: We cross-posted, so I will update the migration guide with that info.  Thanks.

-Dubious-

 

 

Thanks!! I leave this to you and Sharlikran

You didn't make any mistake - home page is not updated automatically, feel free to edit. Github's wiki is not really sophisticated but still works (let's see M$ ruin it...)

Hmm attaching files to a wiki may be a little trickier than editing pages - you need to clone the wiki (it's a repo). Add the WFProfile.cmd as another wiki page I'd say

Share this post


Link to post
Share on other sites

Watch out for a newcomer who may pop in either here or at GitHub .. MarkDF (See posts on oldrim Wrye Bash) may be joining to try and help, knows some Python, has mentioned an interest in adding his own patchers to the code.

I know the ESx filestructure pretty well from my work on ReSaver and from poring over them in xEdit... hopefully I can contribute when get a few days off. :-)

Share this post


Link to post
Share on other sites
22 hours ago, Utumno said:

...

Hmm attaching files to a wiki may be a little trickier than editing pages - you need to clone the wiki (it's a repo). Add the WFProfile.cmd as another wiki page I'd say

Out of my comfort zone here.  Clone/repo the wiki?  Why not just add a "new" wiki page (in which case: should it be given a "[dev]" or other tag on the title line)?  Hate to waste your time on such basic matters, so if you can point me to the appropriate docs on how the wiki is organized I should be able to figure it out from there.

-Dubious-

Share this post


Link to post
Share on other sites
5 minutes ago, Dubious said:

Out of my comfort zone here.  Clone/repo the wiki?  Why not just add a "new" wiki page (in which case: should it be given a "[dev]" or other tag on the title line)?  Hate to waste your time on such basic matters, so if you can point me to the appropriate docs on how the wiki is organized I should be able to figure it out from there.

-Dubious-

Yep just add a new wiki page - like WFProfile.cmd no need for dev. I had no time for wiki docs unfortunately :P

Share this post


Link to post
Share on other sites

Some stats after 1 day of Beta3 being up on Nexus

Unique Downloads (These are just the Installer file) :

Skyrim SE = 600

Fallout 4 = 300

Skyrim LE = 700

Fallout NV = 45

Fallout 3 = 19

Oblivion = 430

I think FNV and FO3 communities are still rubbing their eyes, one expressed as much on FO3 comments.

 

Best thing though, out of all of those downloads there is only one bug report, on Oblivion comments, which looks to me like possibly an unusual character in the Windows account user name or something similar ..

No matter what version I use or what I do, I always get the following error when trying to install 'OSR':

Traceback (most recent call last):
File "bash\bolt.pyo", line 723, in tempDir
File "tempfile.pyo", line 337, in mkdtemp
File "ntpath.pyo", line 85, in join
UnicodeDecodeError: 'ascii' codec can't decode byte 0xe9 in position 7: ordinal not in range(128)
Trying to pass temp dir in...
Traceback (most recent call last):
File "bash\balt.pyo", line 2495, in __Execute
File "bash\balt.pyo", line 1605, in _conversation_wrapper
File "bash\basher\installer_links.pyo", line 504, in Execute
File "bash\bosh\bain.pyo", line 2287, in bain_install
File "bash\bosh\bain.pyo", line 2227, in _install
File "bash\bosh\bain.pyo", line 2243, in __installer_install
File "bash\bosh\bain.pyo", line 1006, in install
File "bash\bosh\bain.pyo", line 1192, in _install
File "bash\bosh\bain.pyo", line 1184, in unpackToTemp
File "bash\bolt.pyo", line 1077, in clearReadOnly
File "subprocess.pyo", line 523, in call
File "subprocess.pyo", line 711, in __init__
File "subprocess.pyo", line 959, in _execute_child
UnicodeEncodeError: 'ascii' codec can't encode character u'\xe9' in position 20: ordinal not in range(128)


I just drag and drop the Zip Folder as it is suggested in Predcaliber Video and click 'install' and this happens no matter what. Can someone help me?

Share this post


Link to post
Share on other sites

Only one error report?  See my report in this thread posted immediately after release.  Also for Oblivion.  Issue not the same, I think.

Share this post


Link to post
Share on other sites
On 7/4/2018 at 6:14 PM, sombrero said:

Crash report when starting beta 3.  This is for Oblivion.  Skyrim SE and Skyrim start ok.

File "bash\bash.pyo", line 227, in main
  File "bash\bash.pyo", line 393, in _main
  File "bash\basher\__init__.pyo", line 3981, in Init
  File "bash\basher\__init__.pyo", line 4021, in InitData
  File "bash\bosh\__init__.pyo", line 2726, in refresh
  File "bash\bosh\__init__.pyo", line 1382, in refresh
  File "bash\bosh\__init__.pyo", line 1358, in new_info
  File "bash\bosh\__init__.pyo", line 1277, in new_info
  File "bash\bosh\__init__.pyo", line 393, in __init__
  File "bash\bosh\__init__.pyo", line 274, in __init__
  File "bash\bosh\__init__.pyo", line 405, in _reset_cache
  File "bash\bosh\__init__.pyo", line 1108, in readHeader
  File "bash\bosh\save_headers.pyo", line 62, in __init__
  File "bash\bosh\save_headers.pyo", line 78, in load_header
  File "bash\bosh\save_headers.pyo", line 88, in load_image_data
OverflowError: Python int too large to convert to C long
 

@Utumno Did you catch this one?, seems like some of the BashBugDump has not been reported here so probably missing info you needed.

-------------------

Madpaddy on Fallout 4 Nexus reports this :

"Sooo using the new version and for me, it still seems to be counting the ESL files towards the total IE 295 with ESL 243 without them, but its deselecting mods on startup saying im past the limit ?."

-------------------

Seems like I spoke too soon : Also on Skyrim SE Nexus, we have GSA2011 reporting a problem launching Skyrim LE (I dont know why people do this, but anyway ..) Edit - Actually he spammed the report on three Nexus Pages, so I left the one on Skyrim LE Nexus ..

Copy of report in the spoiler

 

Wrye Bash encountered an error.
Please post the information below to the official thread at:
https://afkmods.iguanadons.net/index.php?/topic/4966-wrye-bash-all-games/& or 
https://bethesda.net/community/topic/38798/relz-wrye-bash-oblivion-skyrim-skyrim-se-fallout-4/

Traceback (most recent call last):
File "bash\bash.pyo", line 227, in main
File "bash\bash.pyo", line 393, in _main
File "bash\basher\__init__.pyo", line 3981, in Init
File "bash\basher\__init__.pyo", line 4018, in InitData
File "bash\bosh\__init__.pyo", line 1955, in refresh
File "bash\bosh\__init__.pyo", line 1702, in _modinfos_cache_wrapper
File "bash\bosh\__init__.pyo", line 1810, in refreshLoadOrder
File "bash\load_order.pyo", line 300, in refresh_lo
File "bash\load_order.pyo", line 250, in _update_cache
File "bash\games.pyo", line 227, in get_load_order
File "bash\games.pyo", line 246, in _cached_or_fetch
File "bash\games.pyo", line 676, in _fetch_load_order
KeyError: bolt.Path(u'Skyrim.esm')

Share this post


Link to post
Share on other sites
19 hours ago, alt3rn1ty said:

 

I think FNV and FO3 communities are still rubbing their eyes, one expressed as much on FO3 comments.

 

Best thing though, out of all of those downloads there is only one bug report, on Oblivion comments, which looks to me like possibly an unusual character in the Windows account user name or something similar ..

 

  Hide contents

 

No matter what version I use or what I do, I always get the following error when trying to install 'OSR':

Traceback (most recent call last):
File "bash\bolt.pyo", line 723, in tempDir
File "tempfile.pyo", line 337, in mkdtemp
File "ntpath.pyo", line 85, in join
UnicodeDecodeError: 'ascii' codec can't decode byte 0xe9 in position 7: ordinal not in range(128)
Trying to pass temp dir in...
Traceback (most recent call last):
File "bash\balt.pyo", line 2495, in __Execute
File "bash\balt.pyo", line 1605, in _conversation_wrapper
File "bash\basher\installer_links.pyo", line 504, in Execute
File "bash\bosh\bain.pyo", line 2287, in bain_install
File "bash\bosh\bain.pyo", line 2227, in _install
File "bash\bosh\bain.pyo", line 2243, in __installer_install
File "bash\bosh\bain.pyo", line 1006, in install
File "bash\bosh\bain.pyo", line 1192, in _install
File "bash\bosh\bain.pyo", line 1184, in unpackToTemp
File "bash\bolt.pyo", line 1077, in clearReadOnly
File "subprocess.pyo", line 523, in call
File "subprocess.pyo", line 711, in __init__
File "subprocess.pyo", line 959, in _execute_child
UnicodeEncodeError: 'ascii' codec can't encode character u'\xe9' in position 20: ordinal not in range(128)


I just drag and drop the Zip Folder as it is suggested in Predcaliber Video and click 'install' and this happens no matter what. Can someone help me?

 

 

11

Yes after all these years WB for fallout3...

Re: bug: Hmm some file in OSR whatever this is ?

12 hours ago, alt3rn1ty said:

@Utumno Did you catch this one?, seems like some of the BashBugDump has not been reported here so probably missing info you needed.

Crash report when starting beta 3.  This is for Oblivion.  Skyrim SE and Skyrim start ok.

File "bash\bash.pyo", line 227, in main
  File "bash\bash.pyo", line 393, in _main
  File "bash\basher\__init__.pyo", line 3981, in Init
  File "bash\basher\__init__.pyo", line 4021, in InitData
  File "bash\bosh\__init__.pyo", line 2726, in refresh
  File "bash\bosh\__init__.pyo", line 1382, in refresh
  File "bash\bosh\__init__.pyo", line 1358, in new_info
  File "bash\bosh\__init__.pyo", line 1277, in new_info
  File "bash\bosh\__init__.pyo", line 393, in __init__
  File "bash\bosh\__init__.pyo", line 274, in __init__
  File "bash\bosh\__init__.pyo", line 405, in _reset_cache
  File "bash\bosh\__init__.pyo", line 1108, in readHeader
  File "bash\bosh\save_headers.pyo", line 62, in __init__
  File "bash\bosh\save_headers.pyo", line 78, in load_header
  File "bash\bosh\save_headers.pyo", line 88, in load_image_data
OverflowError: Python int too large to convert to C long
 

-------------------

Madpaddy on Fallout 4 Nexus reports this :

"Sooo using the new version and for me, it still seems to be counting the ESL files towards the total IE 295 with ESL 243 without them, but its deselecting mods on startup saying im past the limit ?."

-------------------

Seems like I spoke too soon : Also on Skyrim SE Nexus, we have GSA2011 reporting a problem launching Skyrim LE (I dont know why people do this, but anyway ..) Edit - Actually he spammed the report on three Nexus Pages, so I left the one on Skyrim LE Nexus ..

Copy of report in the spoiler

  Hide contents

Wrye Bash encountered an error.
Please post the information below to the official thread at:
https://afkmods.iguanadons.net/index.php?/topic/4966-wrye-bash-all-games/& or 
https://bethesda.net/community/topic/38798/relz-wrye-bash-oblivion-skyrim-skyrim-se-fallout-4/

Traceback (most recent call last):
File "bash\bash.pyo", line 227, in main
File "bash\bash.pyo", line 393, in _main
File "bash\basher\__init__.pyo", line 3981, in Init
File "bash\basher\__init__.pyo", line 4018, in InitData
File "bash\bosh\__init__.pyo", line 1955, in refresh
File "bash\bosh\__init__.pyo", line 1702, in _modinfos_cache_wrapper
File "bash\bosh\__init__.pyo", line 1810, in refreshLoadOrder
File "bash\load_order.pyo", line 300, in refresh_lo
File "bash\load_order.pyo", line 250, in _update_cache
File "bash\games.pyo", line 227, in get_load_order
File "bash\games.pyo", line 246, in _cached_or_fetch
File "bash\games.pyo", line 676, in _fetch_load_order
KeyError: bolt.Path(u'Skyrim.esm')

 

First error I think was fixed a long time ago - i would need the save to debug this and a full bugdump

Can you reproduce the esl limit problem?

Third problem also have seen before and fixed - what it basically says is there is no Skyrim.esm - but IIRC there was something else there

Share this post


Link to post
Share on other sites
19 hours ago, Dubious said:

Okay.  Added the script as a new wiki page and linked it in the "migration guide".  Seems to be working.

-Dubious-

Thanks! I skimmed through and quite liked it :D

One point: you don't need to copy the default ini just create a bash.ini with only relevant sections and key value pairs. This may be simpler than edit the bash_default.ini

Share this post


Link to post
Share on other sites
1 hour ago, Utumno said:

Re: bug: Hmm some file in OSR whatever this is ?

First error I think was fixed a long time ago - i would need the save to debug this and a full bugdump

Can you reproduce the esl limit problem?

Third problem also have seen before and fixed - what it basically says is there is no Skyrim.esm - but IIRC there was something else there

OSR IIRC the only thing with that abbreviation is Oblivion Stutter Remover, an OBSE Plugin, its one of those Script Extender .dll which Bash allows as an exception to install after the user reads the warning.

--------------------------

@sombrero As @Utumno says "i would need the save to debug this and a full bugdump" - :unsure: Not quite sure why I am relaying messages between two people both participating in the same thread :D @Utumno if you have a read of the quoted post by Sombrero it says "Crash report when starting beta 3", so if thats fixed recently then you have a regression in beta 3 we just uploaded to Nexus. I guess if Sombrero gives us a full bugdump instead of a cut down one things will be clearer.

--------------------------

I dont use ESLs and never want to, for me they complicate the Load Order too much

--------------------------

Third problem - Disregard .. Sorry I missed his reply even though I replied after it but he has solved it his self "For anyone having this same issue go to you skyrim folder/Mopy/bash patches and delete all of the found folders. Then install the pythone version instead of the standalone"

How that solved the problem exactly I have no clue, but apparently he also installed Bash for two other games and only had issues with Skyrim LE .. Maybe he didnt use the uninstaller and had one of those old files issues, or registry issues for game path, or a confused Python and Standalone installation :shrug:

Share this post


Link to post
Share on other sites
3 minutes ago, alt3rn1ty said:

OSR IIRC the only thing with that abbreviation is Oblivion Stutter Remover, an OBSE Plugin, its one of those Script Extender .dll which Bash allows as an exception to install after the user reads the warning.

--------------------------

@sombrero As @Utumno says "i would need the save to debug this and a full bugdump" - :unsure: Not quite sure why I am relaying messages between two people both participating in the same thread :D @Utumno if you have a read of the quoted post by Sombrero it says "Crash report when starting beta 3", so if thats fixed recently then you have a regression in beta 3 we just uploaded to Nexus.

--------------------------

I dont use ESLs and never want to, for me they complicate the Load Order too much

--------------------------

Third problem - Disregard .. Sorry I missed his reply even though I replied after it but he has solved it his self "For anyone having this same issue go to you skyrim folder/Mopy/bash patches and delete all of the found folders. Then install the pythone version instead of the standalone"

How that solved the problem exactly I have no clue, but apparently he also installed Bash for two other games and only had issues with Skyrim LE .. Maybe he didnt use the uninstaller and had one of those old files issues, or registry issues for game path, or a confused Python and Standalone installation :shrug:

Ok will check OSR when I get round to it - can you reproduce that

----

I noticed but maybe the fix was on the user side not sure anymore. What happens is it crashes on reading a save maybe a stray save? I will add debug prints on next iteration but don't hold your breath

----

esls more info is needed - how many files Bash deactivates?

___

glad that one solved itself

Share this post


Link to post
Share on other sites

I only have Skyrim SE and Fallout 4 these days (had to make room on my limted SSD for Kingdom Come Deliverance .. hogging 41 gigabyte) ..

But just tried all three main files in my Skyrim SE setup :

They all contain an Data \ OBSE folder with plugins etc, so I unpacked them to rename the OBSE folder to SKSE, then repacked them with no further changes - Basicly just to make them Skyrim SE compatible for installation as you would an SKSE plugin setup, and prove they install fine ..

GG4IOiT.png

After clicking "Yes", I had no issues apart from having Oblivion .dlls installed in an SSE setup :)

GOVdezk.png

 

So I cant see why a Beta 3 Wrye Bash for Oblivion would have any issues with installing the same files for obse in an Oblivion setup. LMStearn answered Ebonshire too on Oblivion Nexus and believes Ebonshire may have had a corrupt file

Edit : Just noticed Ebonshire did not mention Beta 3 is in use - Anyway up I think now this may be a PEBCAK

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Support us on Patreon!

×