Jump to content
Arthmoor

Forum Upgrade - IPB 4.2

Recommended Posts

Just a heads up that coming up this weekend we will be performing an upgrade on the site to update to the new IPB 4.2 package that was just released last week. This should bring in a lot of nice new features, and if indications are correct, restore the ability of members to remove their own gallery and download content without having to ask us to do it for you.

Since this is a large upgrade I'm going to take the forum system offline in the afternoon for the duration so that the database doesn't get fouled while we're trying to do this. With any luck it shouldn't take more than an hour or two.

Share this post


Link to post

I hope that we can see the *double line space* between two text lines removed in the post editor and let it be the same way as it was in IPS 3.x.

 

In IPS 4.x

Quote

test line a

 

test line b

 

In IPS 3.x

Quote

test line c

test line d

 

Share this post


Link to post

For me the background image is loading really really late (like 5 seconds after the rest), any chance this might get looked at?

Share this post


Link to post

There's really not much I can do about things like that. They're just how the software works. Screwing around with the templates and/or coding will make future upgrades 10 times harder than they need to be.

Share this post


Link to post

Release notes https://invisioncommunity.com/release-notes/

And the 4.2 features list https://invisioncommunity.com/news/invision-community-42-r1030/

Not sure if they have fixed the spoiler problem (cant find it anyway)

See this post, which before posting was ..

Text

open spoiler tag

image

close spoiler tag

more text

.. The result becomes ..

Text

Spoiler (containing image and the following more text which was expected to be outside and after the spoiler)

Share this post


Link to post

We'll have to see on that I guess. Unfortunately IPB disavows any responsibility for the behavior of the post editor and passes all blame for problems with it off on the people at ckeditor.com. So if that issue is fixed we won't know until the upgrade is done.

Share this post


Link to post

The new feature "Clubs" is similar to what TWC has, which are called "Social groups" I think.

Share this post


Link to post

The upgrade is complete. There may be some quirks here and there due to the extensiveness of it all but a quick run around to check on things seems to indicate all is well so far.

Share this post


Link to post

Kudos @Arthmoor   This version looks great and I've not run into any issues, although this is the first post I've made. :beer:

Seems faster too. I hotrod servers running PHP for a living (specifically kernel-level tweaking for Linux and FreeBSD boxen) and this seems like it is loading faster than the previous version.

Share this post


Link to post

BTW, for those of you who have asked about it in the past, check to see if you can delete your own gallery and download entries.

Also be aware that the background image fade thing isn't working quite how I'd like it so that may end up being tweaked until it gets back to working and looking like it did before the update.

Share this post


Link to post

Nice new look. Sleek.

I still, however, see no way to delete either my own images, or my own files.

Share this post


Link to post

Ugh, I don't like the color for the top bar where you login or logout and having that *intense* dark orange in combination with the current background hurt my eyes.

 

Is it possible to change color for the top bar to a more matching color?

 

Scratch that... It seems the color for the top bar is tied to what background image a member has chosen.

 

 

EDIT:  Just notice there is a "Start new topic" button in the forum main page.  Is that normal or can we compose a new thread without first navigating to the forum we wanted to post a new thread?

Share this post


Link to post

:bigcookie: :beer: (what?, cookies and beer is fine, especially real ales with dead beetles floating around for extra protein)

Looks like a good update so far.

 

Where do we do Status updates these days ?, there used to be a line which said "Whats on your mind .." .. Cant seem to find it

Share this post


Link to post
1 hour ago, alt3rn1ty said:

Where do we do Status updates these days ?, there used to be a line which said "Whats on your mind .." .. Cant seem to find it

Go into your profile and click on the "See my activity" button to the top right and from there look to the top left in the menu for "Status updates".

Share this post


Link to post
7 hours ago, alt3rn1ty said:

Where do we do Status updates these days ?, there used to be a line which said "Whats on your mind .." .. Cant seem to find it

It's on the main Profile page, it's called "your own feed" now lol (I think it was there before too, I haven't done status in a while)

afkforum.thumb.jpg.3749c362a2f2f7e36362ad9063201ca2.jpg

I also wonder why the grey header on my profile page is larger than yours .....

Share this post


Link to post

Ah good someone who actually knows, thanks Hana

The space thing .. I'm using Chromium (open source pre-google Chrome builds), and also use UBlock Origin, so maybe a difference in handling the web page code between our browsers.

Share this post


Link to post

On Edge browser the static top banner flickers when i follow links to a specific post from the main page, i.e.: i click on the link to the latest post in a forum instead of clicking through the individual forums/thread links.

Anyone else see this?

 

on the other hand, the weird scrolling behavior i had with the background image no seems to be fixed (at least on computers that have access to somewhat recent intel gpu drivers). The loading times of the background image however are unchanged (as expected).

 

all in all, i think the upgrade is really good looking and works well.

Share this post


Link to post

Just wanted to note that I have disabled the image blur effect that was causing the ugly grey below the bottom of the background image size. I think the whole thing looks much better without the blur anyway and it seems to have further eliminated some lingering scroll lag.

Share this post


Link to post
7 hours ago, Gruftlord said:

On Edge browser the static top banner flickers when i follow links to a specific post from the main page, i.e.: i click on the link to the latest post in a forum instead of clicking through the individual forums/thread links.

Anyone else see this?

 

On Edge get the banner flickering across the top of the page while scrolling up from this page at certain points in the scroll.

Share this post


Link to post

That would be something that would have to be documented and reported to the people who make the theme. I don't have Windows 10 so I can't load the site in Edge to check it which means I can't file the report myself because I have no idea what to even look for.

Has anyone using Edge checked to see if the same problem happens in the IPB default theme?

Share this post


Link to post
13 hours ago, lmstearn said:

On Edge get the banner flickering across the top of the page while scrolling up from this page at certain points in the scroll.

upon further observation, this seem to be the case for me as well. it doesn't seem to be related to how i got to the page, like i assumed at first.

sometime it works, sometime it doesn't. very odd.

edit: if you do not see any issue on Win < 10 and browser =/= edge, that's already a usefull info i'd say Arthmoor.

how would i switch the theme, to test what you suggest?

edit 2: found it. There is no static top banner on the default theme as far as i can see. naturally, the problem doesn't present itself there.

 

 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Support us on Patreon!

×