Jump to content
Sign in to follow this  
Lonewanderer

Caretaker spawns at the wrong location

Recommended Posts

Hello,

just a fast question/report: I am using Fallout 4, version 1.9.4 (did not yet install the CC patch). I have only 2 mods (except UFO4P), both made by me:

1) Change the loading screen parameters for the loading screens from DLC1 (Automatron): DLC01LoadScreenRate from 20.0 to 5.0

2) Change the Chance for Automatro RE: DLC01REPercentChance from 50.0 to 25.0

These changes were discussed here in a thread, but are not a bug fix. I checked with xEdit - these two changes are the only records in the Mod. It was created with xEdit (FO4Edit). Both values are under DLC01/globals

The second 'mod' is just a changed script, namely 'DLC01/DLC01MQ00Script.pex'. This script (responsible to start the Automatron main quest) has a function which starts the DLC at level 15. Since I find this much too early, I changed the level check. The DLC will start at level 30, or earlier, if I remove the script. I complied the script myself and load it as 'loose file'. There is actually only one number changed from 15 to 30, the rest is original. (This script is not changed by UFO4P, so it does no harm to this too).

This is the background. Load order is fine, UFO4P (version 2.01a) is loaded after the official DLCs.

Now I have a curious bug, and it is clearly a bug: I received the 'Mercer Safehouse quest' from PAM, and it was Outpost Zimonja. I cleared the raiders, and the quest was solved, acknowledged by PAM, and I received the next quest. But since I played it more than once, I know, that a NPC named 'Caretaker' appears immediately after establishing the safehouse. (Normally after you build the defenses, and the quest goes to 'Report to PAM').

But this time the Caretaker was missing. I continued to play, but during a later visit at Outpost Zimonja still no Caretaker was found. So I tried something: I looked up the prid from the Caretaker and teleported my character to him. This worked fine.

The Caretaker was at Abernathy Farm!

He started the usual dialog, gave me his quest, all seemed fine, only his location is totally wrong. I did not have, and still do not have Abernathy farm as a settlement, I never visited it.

Next try (reloaded a save from before the teleport above) - teleport the Caretaker to me at Outpost Zimonja. Again the dialog worked fine, I received the quest, and after this the Caretaker started walking towards Abernathy Farm. So he was set with the wrong location as 'home', and additionally according to the Wiki Abernathy Farm is not a possible location for the Mercer Safehouse.

Something is very wrong here - it is not game breaking, but something goes wrong. This is the first game I started completely new with UFO4P, without using any save from an older game.

So: New game, started with 1.9.4, UFO4P 2.01a (last version), only the mods mentioned above. I used Google - and this seems to happen to others too, one poster here has exactly the same problem:

 

I did not see the NPC, but the rest is identical. I will report it in the Bug Tracker...

Edit: This issue is already in the bugtracker under #20685. I commented it.

Edit - update:

I experimented a bit. I restored a save before this quest. I tried to do things different, but every time PAM selected Outpost Zimonja as the Mercer Safehouse. Seems this quest is determined earlier.

Next try: I tried to acquire Outpost Zimonja before going to PAM. So I killed the Raiders, and had the outpost as a settlement. No people, a bit of food, 2 beds, no defenses. When I went to PAM, she again used Outpost Zimonja, and the quest asked to build defenses (as usual).

Netx try: I acquired Outpost Zimonja, and build defenses, 16 points (two turrets). Then I went to PAM. Again Outpost Zimonja, but this time it said: Build defenses (16%)! So the quest script does not calculate correctly, it thinks that 16 defense value is equal to 16%. So I went to Outpost Zimonja and still it said I had 16%. But when I stored one turret (defens value 8) in the workbench, the percent value went to 80%, and taking the turret out again and mounting it, concluded the quest. This is the result I will keep, btw.

Now - after the last try the quest ended ('Go to PAM'), and I saw the Caretaker! He spawns immediately after the quest ends. And he started to walk towards Abernathy Farm. When I talked to him, he gave his quest. Afterwards he continued to walk to Abernathy (I think it is always Abernathy, this seems to be an error in the quest setup). This time I did not use console commands in any way.

I will continue to play with this bug. I am curious where the quest arrow will point to, when I solve the Caretakers quest.

Edit 3: The issue with the wrong defense value (in the case one already has acquired Mercer Safehouse as settlement), where the actual defense point value is taken as percent value, instead of calculating it from the needed value (10) and the actual value, is already in the bug tracker, as issue #21123. I commented on it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

Support us on Patreon!

×