Jump to content
somethingbrite

Mole Rat game freeze bug is baffling me....

Recommended Posts

OK, so I have observed a situation whereby a molerat ambush triggered during 2 quests so far has resulted in a game freeze. (well, to be accurate the game does not freeze until you either try to save or exit the cell once the trigger has occured.) 

This occurs in "Hole in the Wall" quest (Vault81Secret cell) and Shamrock Taphouse - when entering the room with the microbrewing protectron. 

The issue is also described here - https://afkmods.iguanadons.net/index.php?/topic/5304-a-problem-with-molerats-not-the-disease-something-else/

I did a bunch of testing and I think I have found at least part of the problem, but I can't for the life of me figure out what mechanic is actually causing it.

A series of run's through Vault81Secret with various different conditions set reveals that the mod "Scrap Everything" will cause the issue with 100% repeatability when it is enabled. If this mod is disabled then the issue does not occur. 

So, great, that identifies the culprit right? Well, maybe, maybe not. I have also noticed that even with this mod active, as long as the Mole rats do not actually detect the player (or companion I guess) and become hostile then the issue does not occur. - and it is this part which confuses me. I can't find anything in the Scrap Everything .esp which would impact the mole rats actual behaviour or that explains the subsequent freeze. 

In both Hole in the Wall (Vault81Secret) and Shamrock taphouse there appear to be actual trigger markers which will trigger the mole rat ambush. It is the point where these trigger that the problem will start from but...it's more complicated than that it seems...

Testing conditions. (all testing so far has been in vault81secret)

coc vault81secret from recent save inside vault81 or load up really old save and enter "Hole in the Wall" from start (inside vault81) = no difference to outcome. 

All run's were performed from the same save point's with console initiated save's made at 3 subsequent points (or until the game breaks)

Testing save points = Before first trigger. After 2nd Trigger and Inside Curies lab. - failure would normally occur after first trigger. 

  • All mods on. = Issue does occur.
  • All mods off. = Issue does not occur. 
  • All mods ON except Scrap Everything = Issue does NOT occur
  • All mods OFF except Scrap Everything = Issue does occur
  • (UFO4P enabled / disabled makes zero difference)

On the nexus pages for Scrap Everything the author makes some comment related to a report of this bug that .ini edit's of bUseCombinedObjects should not be used, however testing with bUseCombinedObjects=1 or bUseCombinedObjects=0 - or indeed no entry at all seems to make no actual difference. All conditions were tested with this variation and in itself it made no difference. As long as Scrap Everything is active in the load order then the game will freeze. 

HOWEVER (and here is where it gets interesting.)

Having established that the mod Scrap Everything is part of the problem I did several run throughs with various AI toggles in order to try to identify the actual mechanism that breaks the game.

  • tAI - Has no effect. The ambush is still triggered by passing the trigger point and while the mole rats will not exit their tunnels the game will still be broken from that point. 
  • tDetect = inhibits the molerat AI from detecting player or companion. - With this toggled the issue does NOT occur! The mole rat ambush will still be triggered by trigger markers when you pass them, but the mole rats will not aggro and it is possible to save and/or exit the cell without freeze. 
  • Toggling tDetect back at any point after then allows the mole rats to aggro and....the problem occurs. 

So, the problem also seems linked to the mole rat behaviour. It seems in fact to be the point at which they aggro which breaks the game. - and that is the mechanic that I cannot understand. 

I looked through Scrap Everything - Ultimate Edition.esp with FO4Edit and yes, the plugin does have the mole rat ambush furniture in it. - But even removing all reference to these in the plugin has zero impact. 

I also can't really understand why it would be the mole rat aggro which is the point where the break occurs rather than (for example) the appearance of the mole rat tunnel exit decals, the tunnels or mole rat carcasses as these things might be the kind of thing included in a scrap mod. 

I'm going to drop a comment on the mod page itself, but if anybody with better knowledge of these things can offer any insight at all into why this happens and what the mechanic is then it would be very much appreciated. I really would like to understand the game mechanic a little better and who knows? One day maybe I'll fix a mod or make one myself. 

 

Edited by somethingbrite
clarity

Share this post


Link to post
Share on other sites

Whats you line of thought there? I'll give it a try tomorrow and let you know the result. 

I had thought the issue may be related to their dead bodies (which might reasonably have been included to a scrap mod) and their seems to be a mole rat that starts dead in vault81secret anyway. But if I use tDetect to stop the remaining ones from going into combat mode their standard walking around ai kicks in and it's still possible to save and/or leave the cell even though the ambush has triggered and the mole rats are active. Can't remember at that point if I have then killed them and what the impact of that is. I'll try disable on them and get back to you. 

Am also going to see what impact toggling the combat ai off has, think I saw a console command for that online. 

Share this post


Link to post
Share on other sites

Hi there somethingbrite,

you are definitively not alone with this bug. It is mentioned on steam a couple of times:

https://steamcommunity.com/app/377160/discussions/0/144513248282521815/

https://steamcommunity.com/app/377160/discussions/0/360670708776433033/

And I think I have seen discussions about it on Reddit as well, although no one has ever found a real solution for it.  I just wanted to thank you for the trick with "tDetect". I have been dealing with this bug for months now, and I have been researching all over the internet but unfortunately haven't found a real solution yet. Until now I always just used the "killall" command before I have even seen the molerats. However your work-around seems to be a bit more immersive. If you ever find a better and more permanent fix for this, I would be glad you could share this here.  :)

 

Edit: I just noticed something weird. If I use tdetect and my NPC's trigger the molerat-aggression (not me, as they can't detect me), then the bug doesn't occur either.

Other observations;

- the bug only occurs if the molerats are in an indoor cell, not if they are outdoors

- however, when playing through "South of the Sea" I found that it also affects radscorpions that are encountered underground (they aren't found underground in Vanilla Fallout 4)

- for me disabling Scrap Everything didn't solve the problem, and I also didn't have the faulty mesh from CBBE. So the same bug can be triggered by various causes.

 

Thinking out loudly:

- do both molerats and radscorpions have the same attack script?

- is that script different if triggered underground?

- is that script so badly written that it can corrupt at a whim? - potential for streamlining that script?

Edited by aufisch
Added new information

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Support us on Patreon!

×